公式作品のパペットについて



  • 公式作品のパペットを参考にロボットを作成しているのですか、yaw軸サーボの動作を反転させることは可能でしょうか。
    可能であればどこを変更すればいいか教えていただきたいです。

    よろしくお願いいたします。


  • administrators

    @bまてるだ さん

    こちらのパペット人形ですね
    https://obniz.io/explore/36

    加速度やposenetの計算後,実際にサーボモーターに角度の命令を送っているところは下記になります.

    function setServo(yaw, pitch) {
            try {
                servo_y.angle(yaw);
                s_yaw = yaw;
                servo_p.angle(pitch);
                s_pitch = pitch;
                $('#d4').html("SERVO: " + s_yaw.toFixed(2) + ", " + s_pitch.toFixed(2));
            } catch (e) {
                console.error(e);
                return;
            }
        }
    

    例えば,こちらで
    servo_y.angle(yaw);servo_y.angle(180-yaw);のように変更いただければ,サーボの動きが反転します.

    こちらで試してみていただけますか?



  • @kido
    回答ありがとうございます。
    変更した結果、反転に成功いたしました。

    ありがとうございました。


 

Recent Projects

  • @nak435 ありがとうございます。
    接続は3.3vのgnd以外同じでした。
    エラーはそのせいかもしれませんが、しかし電気的にはgndを繋がない場合3.3vとしてうまく供給できないはずなのでそこが不思議です。

    教えていただいたプログラムの部分を修正して試してみたいと思います。
    また少し時間がかかりそうなのですが、早めに試したいと思います。

    引き続きよろしくお願い致します。

    read more
  • @Yuki-Sato さん、
    まずは、ピン接続だけ確認してください。

    i2cエラーは、私の方でもう少し調べてみます。

    read more
  • @Yuki-Sato さん

    vccに3.3v、それ以外はobnizの1-5まで直接接続で合っていますでしょうか。

    その通りで合ってます。Flick Hatはいつもそれで動かしていますし、お借りしたLargeもその接続で動作しました。(その後、6-7も接続してLEDの確認もしましたが)

    まったく動かない訳ではないようなので、接続の問題ではない気もしますが、前回のときより前進しているでしょうか? 同じでしょうか?
    ただ、私の場合は、書き込み(i2c.write)がエラーになった記憶が無いです(忘れているだけ?)

    3.3vは外から取っていると思いますが、外からのgndはどうしていますか?
    私の場合は外からのgndを接続するとうまく動作しなかったので、外からは3.3vの1線だけ接続しています。(私の知識では、gndと対でなければ+3.3Vにならないと思うのですが、接続してしまうとなぜか動きませんでした。)

    ↑ここまでで佐藤さんと私でpin接続が同じであれば、FlickHat.jsのstart()内の2個所のi2c.writeを削除して試してもらえませんか? このwriteは無くても動作しますので。もしくは下記2行が不要かも知れません。writeを残して、この2行を削除して試していただけますか。

    73 await this.polling(); 74 await this.obniz.wait(200);

    追伸;

    また、まれですが26バイトの読み取りに失敗することもあります。

    これは同じでエラーになることがあります。どこかの制御に問題があるのでしょうか?

    read more
  • @nak435 こんにちは。

    flick-demo.htmlを使って動作確認しています。
    接続の確認なのですが、vccに3.3v、それ以外はobnizの1-5まで直接接続で合っていますでしょうか。

    なかなかうまく通信できないでいます。
    エラーが出ず何度かpollingできることもあるのですが、どこかのタイミングでエラーとなってしまいます。

    最初の段階は比較的うまくいって、132バイトを受信できています。

    [Log] Obniz: {"i2c0":{"mode":"master","address":66,"data":[132,0,0,131,170,99,128,230,19,100,21,32,49,46,51,46,49,52,59,112,58,72,105,108,108,115,116,97,114,86,48,49,59,120,58,32,32,32,32,32,32,32,32,59,68,83,80,58,73,68,57,48,48,48,114,50,57,54,51,59,105,58,66,59,102,58,50,50,53,48,48,59,110,77,115,103,59,115,58,82,101,108,95,49,95,51,95,112,114,101,114,49,55,56,52,58,78,77,59,0,0,0,0,0,0,0,0,0,0,0,0,0,0,14,0,0,85,170,144,101,32,32,128,15,255,255,255,255,225,242,0,0]}} (logger.min.js, line 1)

    ただ、その後に以下のような書き込みを行うところで書き込めずエラーとなることが多いです。

    [Log] Obniz: send: [{"i2c0":{"address":66,"data":[16,0,0,162,161,0,0,0,31,0,0,0,255,255,255,255]}}] (logger.min.js, line 1)

    また、まれですが26バイトの読み取りに失敗することもあります。

    接続方法が違うか、Flick Largeだと良くないのかなと思っています。
    接続方法について、合っているか教えていただけますでしょうか。よろしくお願い致します。

    read more