JpegSerialCam の setBaudWait() が応答しない。



  • 以下のようなソースを実行したところ、cam.setBaudWait(9600); から応答が返ってきません。

      var cam = obniz.wired("JpegSerialCam", {vcc:0, cam_tx:1, cam_rx:2, gnd:3});
      await cam.startWait({baud: 19200});
      console.log('complete startWait()');
      await cam.setBaudWait(9600);
      console.log('complete setBaudWait()');
      await cam.setSizeWait("160x120");
      console.log('complete setSizeWait()');
    

    直前までcam.setBaudWait(9600);を呼んでいなかったのですが、そのときは正常に画像を取得できていました。

    setBaudWait()を呼ばずに成功したあとにsetBautWait(115200)を実行したところ、応答が返ってこず、それ以降はsetBaudWait()を呼んでも呼ばなくても応答が返ってきません。

    setBaudWait()を呼んでいないときは、setTimeWait()で応答が返ってこなくなります。

    どのような原因が考えられるでしょうか?
    また、boudは電源を切断しても設定が残るとのことでしたが、これを初期化することは可能でしょうか?



  • 追加の情報です。

    setBaudWait()を呼び出すと、以下のようなデータをwebsocketに送り続けていました。
    ただ、正常に動作していたときの通信は見ていないので、これが正常なのかどうかは判断できないのですが、、、

    0_1544714981531_4338c057-870a-4dab-839b-39e7ea7d99cb-image.png



  • 自己解決しました

    setBaudWait()で変更したあと、次の起動時のstartWait()で指定するbaudが異なっていたために接続できていないだけだったようです。


  • administrators

    @はしもとおさむ こんにちは。遅くなってすいません、解決されたとのことでよかったです。
    このカメラは設定を保存して次回にも利用するのでこのような動きになります。
    設定が保存されるということをもう少し分かりやすく記載します。


 

Recent Projects

  • @nak435 かしこまりました。よろしくお願いします。

    read more
  • @Yuki-Sato さん、

    外部の3.3vを使うとはいえ普通にvccやgndを供給して問題なくうごくのであれば、弊社での動作確認後Flick Hatのライブラリとして公開できればと思っているのですがいかがでしょう。

    今週末に確認しますので、お待ちください。

    read more
  • @nak435 時間がかかってすいません、

    なんとか3.3vをgndにつないでFlick Largeを動かしたかったのですが、うまく動かすことができなかったです。
    3.3vをgndを繋がずに接続するというのはライブラリで推奨して伝えることは難しいと思ってます。

    Flick LargeでなくFlick Hatの方で、外部の3.3vを使うとはいえ普通にvccやgndを供給して問題なくうごくのであれば、弊社での動作確認後Flick Hatのライブラリとして公開できればと思っているのですがいかがでしょう。

    よろしくお願い致します。

    read more
  • @nak435 ありがとうございます。
    接続は3.3vのgnd以外同じでした。
    エラーはそのせいかもしれませんが、しかし電気的にはgndを繋がない場合3.3vとしてうまく供給できないはずなのでそこが不思議です。

    教えていただいたプログラムの部分を修正して試してみたいと思います。
    また少し時間がかかりそうなのですが、早めに試したいと思います。

    引き続きよろしくお願い致します。

    read more