ioAnimationの仕様について



  • ioAnimationの仕様についての質問です。
    Websocket APIでioAnimationのサンプルコードのJSONについて、そのままでは動かず、"animation"を一つ削ると動きました。こちらドキュメントの間違いでしょうか。
    https://obniz.io/doc/sdk/doc/websocket#ioAnimation

    ・このサンプルでは動かず
    [
    {
    "io": {
    "animation": {
    "animation": {
    "name": "animation-1",
    "status": "loop",
    "states": [
    {
    "duration": 500,
    "state": {
    "io0": true
    }
    },
    {
    "duration": 500,
    "state": {
    "io0": false
    }
    }
    ]
    }
    }
    }
    }
    ]

    ・このように変えたら動きました。
    [
    {
    "io": {
    "animation": {
    "name": "animation-1",
    "status": "loop",
    "states": [
    {
    "duration": 500,
    "state": {
    "io0": true
    }
    },
    {
    "duration": 500,
    "state": {
    "io0": false
    }
    }
    ]
    }
    }
    }
    ]


  • administrators

    @Yusuke Matsushita さん

    ご指摘ありがとうございます。
    ドキュメントの間違いです。

    修正しましたので、ご確認いただければと思います。



  • @kido 早急な対応ありがとうございました!


 

Recent Projects

  • @nak435 かしこまりました。よろしくお願いします。

    read more
  • @Yuki-Sato さん、

    外部の3.3vを使うとはいえ普通にvccやgndを供給して問題なくうごくのであれば、弊社での動作確認後Flick Hatのライブラリとして公開できればと思っているのですがいかがでしょう。

    今週末に確認しますので、お待ちください。

    read more
  • @nak435 時間がかかってすいません、

    なんとか3.3vをgndにつないでFlick Largeを動かしたかったのですが、うまく動かすことができなかったです。
    3.3vをgndを繋がずに接続するというのはライブラリで推奨して伝えることは難しいと思ってます。

    Flick LargeでなくFlick Hatの方で、外部の3.3vを使うとはいえ普通にvccやgndを供給して問題なくうごくのであれば、弊社での動作確認後Flick Hatのライブラリとして公開できればと思っているのですがいかがでしょう。

    よろしくお願い致します。

    read more
  • @nak435 ありがとうございます。
    接続は3.3vのgnd以外同じでした。
    エラーはそのせいかもしれませんが、しかし電気的にはgndを繋がない場合3.3vとしてうまく供給できないはずなのでそこが不思議です。

    教えていただいたプログラムの部分を修正して試してみたいと思います。
    また少し時間がかかりそうなのですが、早めに試したいと思います。

    引き続きよろしくお願い致します。

    read more