音がしているにもかかわらずAE_MICAMPの戻り値が常に0近辺



  • テレビ等の音がする環境でも戻り値が常にゼロ近辺です。センサーを別個体に交換しても同様でした。確認をお願いします。

    0_1547208592050_DSC_0149.JPG

    // Javascript Example
    var microphone = obniz.wired("AE_MICAMP", {gnd:5, vcc:6, out:7});
    microphone.onchange = async function(voltage){
    obniz.display.clear();obniz.display.print("");obniz.display.print("");obniz.display.print(voltage);
    await obniz.wait(500);
    }


  • administrators

    @Google-Homer ゼロ近傍になるのですか?
    通常であればこのセンサーは音がない環境で電源電圧の半分になるので2.5v程度になるはずです。

    仮にこのようにしても、やはり0ばかり出るでしょうか。

    var microphone = obniz.wired("AE_MICAMP", {gnd:5, vcc:6, out:7});
    microphone.onchange = async function(voltage){
      console.log(voltage)
    }
    


  • 下記コードで試しましたがダメでした。
    <script>
    var obniz = new Obniz("XXXX-XXXX");
    obniz.onconnect = async function () {

    // Javascript Example
    var microphone = obniz.wired("AE_MICAMP", {gnd:5, vcc:6, out:7});
    microphone.onchange = async function(voltage){
    console.log(voltage)
    }
    }

    </script>

    以下console.log()の結果です。

    0_1547947921624_b2748d8d-5446-4eef-a78f-425174fc9ded-image.png


  • administrators

    @Google-Homer こちら、社内でももう一度確認を行います。使われているobniz.jsのバージョンを教えていただけますか?



  • 下記部分ですかね。

    <html>
    <head>
    <meta charset="utf-8">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <script src="https://obniz.io/js/jquery-3.2.1.min.js"></script>
    <script src="https://unpkg.com/obniz@1.15.2/obniz.js" crossorigin="anonymous"></script>
    </head>
    <body>


  • administrators

    @Google-Homer
    確認したところ、確かにセンサーの値をうまく取得できませんでした。
    このセンサーは非常にセンシティブで、vcc,gndの電圧変動にかなり弱いようで、obnizからの給電では値がうまく取れないようでした。
    ライブラリを作成した時点では弊社の開発環境を使っていたのでより安定した供給ができていたのかもしれません。(もしくはブレッドボードを経由していた影響かもしれません)

    vcc,gndを外部から供給して頂ければ安定して利用できるかと思いますが、そのぐらいしか対応策がありません。
    ライブラリとしてあまりよい状態でないのでこのセンサーについては新しいバージョンのobniz.jsからライブラリから外したいとおもいます。

    お手数おかけして申し訳ございません。


 

Recent Projects

  • @nak435 かしこまりました。よろしくお願いします。

    read more
  • @Yuki-Sato さん、

    外部の3.3vを使うとはいえ普通にvccやgndを供給して問題なくうごくのであれば、弊社での動作確認後Flick Hatのライブラリとして公開できればと思っているのですがいかがでしょう。

    今週末に確認しますので、お待ちください。

    read more
  • @nak435 時間がかかってすいません、

    なんとか3.3vをgndにつないでFlick Largeを動かしたかったのですが、うまく動かすことができなかったです。
    3.3vをgndを繋がずに接続するというのはライブラリで推奨して伝えることは難しいと思ってます。

    Flick LargeでなくFlick Hatの方で、外部の3.3vを使うとはいえ普通にvccやgndを供給して問題なくうごくのであれば、弊社での動作確認後Flick Hatのライブラリとして公開できればと思っているのですがいかがでしょう。

    よろしくお願い致します。

    read more
  • @nak435 ありがとうございます。
    接続は3.3vのgnd以外同じでした。
    エラーはそのせいかもしれませんが、しかし電気的にはgndを繋がない場合3.3vとしてうまく供給できないはずなのでそこが不思議です。

    教えていただいたプログラムの部分を修正して試してみたいと思います。
    また少し時間がかかりそうなのですが、早めに試したいと思います。

    引き続きよろしくお願い致します。

    read more