ArduCAM-Mini-2MP-Plusのサンプルコードを動かすとエラーが出る



  • こんにちは。

    JSパーツライブラリにある「ArduCAM-Mini-2MP-Plus」を購入し起動確認をしております。

    コードを実行してみると、コンソールに「Error: unknown chip 9793」と表示されます。
    この回避策がありましたらご教授願いたいです。
    次のコードで確認しています。

    <!-- HTML Example -->
    <html>
    <head>
    <meta charset="utf-8">
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <script src="https://obniz.io/js/jquery-3.2.1.min.js"></script>
    <script src="https://unpkg.com/obniz@latest/obniz.js"></script>
    </head>
    <body>
    
    <div id="obniz-debug"></div>
    <img id="image">
    
    <script>
    var obniz = new Obniz("OBNIZ_ID");
    obniz.onconnect = async function () {
      obniz.io11.output(true);
      var cam = obniz.wired("ArduCAMMini", { cs:0, mosi:1, miso:2, sclk:3, gnd:4, vcc:5, sda:6, scl:7, spi_frequency:1000000, spi_drive:"5v",module_version:1 });
      await cam.startupWait();
      const data = await cam.takeWait('1024x768');
      console.log("image size = " + data.length + " bytes");
    
      const base64 = cam.arrayToBase64(data);
      document.getElementById("image").src = "data:image/jpeg;base64, " + base64;
    }
    </script>
    </body>
    </html>
    

  • administrators

    @まえぷー さん

    arducamのバージョンの違いによるエラーが出ているようです。

    arducamにはOV2640が搭載されているのですが、
    OV2640のchipIDが9794(0x2642)と9793(0x2641)に2種類あるようです。

    obniz.jsがchipIDが9794(0x2642)のものにしか対応していませんでしたので、
    次回のobniz.jsのアップデートにて対応したいと思います。



  • お忙しいところご確認下さり、ありがとうございます。
    アップデート待ってます(^^)


  • administrators

    @まえぷー さん

    今週リリースしたobniz.js v2.5.0でおそらく対応できたと思いますのでお試しください


 

Recent Projects

  • @nak435 かしこまりました。よろしくお願いします。

    read more
  • @Yuki-Sato さん、

    外部の3.3vを使うとはいえ普通にvccやgndを供給して問題なくうごくのであれば、弊社での動作確認後Flick Hatのライブラリとして公開できればと思っているのですがいかがでしょう。

    今週末に確認しますので、お待ちください。

    read more
  • @nak435 時間がかかってすいません、

    なんとか3.3vをgndにつないでFlick Largeを動かしたかったのですが、うまく動かすことができなかったです。
    3.3vをgndを繋がずに接続するというのはライブラリで推奨して伝えることは難しいと思ってます。

    Flick LargeでなくFlick Hatの方で、外部の3.3vを使うとはいえ普通にvccやgndを供給して問題なくうごくのであれば、弊社での動作確認後Flick Hatのライブラリとして公開できればと思っているのですがいかがでしょう。

    よろしくお願い致します。

    read more
  • @nak435 ありがとうございます。
    接続は3.3vのgnd以外同じでした。
    エラーはそのせいかもしれませんが、しかし電気的にはgndを繋がない場合3.3vとしてうまく供給できないはずなのでそこが不思議です。

    教えていただいたプログラムの部分を修正して試してみたいと思います。
    また少し時間がかかりそうなのですが、早めに試したいと思います。

    引き続きよろしくお願い致します。

    read more