UART APIのrts-ctsオプション



  • ハードウェアフロー制御を使用する機器とのUART通信を行おうとしています。

    "rts-cts"オプションをつけてstart()を呼び出した場合、
    必ずError: Error module=4 func=0 err0=0 returned=1というエラーが発生してしまいます。

    問題切り分けのためobniz単独のuart0↔uart1間でフロー制御を用いるUART通信環境を作成してみましたが、現象が変わらず同じエラーが発生します。

    "rts-cts"オプションを有効にするための条件はありますか?

    (2018/10/16 16:25追記)

    • FW ver: 1.0.10
    • js SDK ver: 1.12.2

  • administrators

    @ERi-Sugawara ご連絡ありがとうございます。
    調査致しますのでしばらくお待ち下さい。


  • administrators

    @ERi-Sugawara お待たせいたしました。ファームウェアに問題が見つかり、修正いたしました。
    数日中に新バージョンとしてリリースいたしますので、obnizのファームウェアを更新していただければと思います。
    リリースまで今しばらくお待ち下さい。


  • administrators

    @ERi-Sugawara 大変お待たせ致しました。
    ファームウェア1.0.11をリリースしました。
    obnizをアップデート頂くことでエラーなくご利用いただけます。
    よろしくお願いします。


 

Recent Projects

  • @nak435 かしこまりました。よろしくお願いします。

    read more
  • @Yuki-Sato さん、

    外部の3.3vを使うとはいえ普通にvccやgndを供給して問題なくうごくのであれば、弊社での動作確認後Flick Hatのライブラリとして公開できればと思っているのですがいかがでしょう。

    今週末に確認しますので、お待ちください。

    read more
  • @nak435 時間がかかってすいません、

    なんとか3.3vをgndにつないでFlick Largeを動かしたかったのですが、うまく動かすことができなかったです。
    3.3vをgndを繋がずに接続するというのはライブラリで推奨して伝えることは難しいと思ってます。

    Flick LargeでなくFlick Hatの方で、外部の3.3vを使うとはいえ普通にvccやgndを供給して問題なくうごくのであれば、弊社での動作確認後Flick Hatのライブラリとして公開できればと思っているのですがいかがでしょう。

    よろしくお願い致します。

    read more
  • @nak435 ありがとうございます。
    接続は3.3vのgnd以外同じでした。
    エラーはそのせいかもしれませんが、しかし電気的にはgndを繋がない場合3.3vとしてうまく供給できないはずなのでそこが不思議です。

    教えていただいたプログラムの部分を修正して試してみたいと思います。
    また少し時間がかかりそうなのですが、早めに試したいと思います。

    引き続きよろしくお願い致します。

    read more